The translation of this page isn't yet complete. Until it is, unfinished parts use the English original.

showimage-icon_64.pngShowImage

Deskbar:No entry, normally launched via double-clicking a supported file.
Location:/boot/system/apps/ShowImage
Settings:~/config/settings/ShowImage_settings


ShowImage allows you to view images in all formats that are supported through DataTranslators. New formats are automatically recognized when their translator is added to the system. This has been done for Haiku's vector icon files, WonderBrush images or when WebP images became available, for example.
ShowImage provides minimal editing features to crop, rotate and flip images and to save them in another format.

indexViewing

showimage-view.jpg

The View menu offers to start a Slide show of all images in a folder (or query result window) and set a Slide delay from 2 to 20 seconds.

Other commands apply to the currently displayed image (without changing the size of the window):
Original size shows the image with a 100% zoom factor.
Fit to window shrinks the image back into the window frame, e.g. after having zoomed into it or after resizing the window.
Zoom in and Zoom out move into and out of the image in 10% steps. Zooming is also done with the mouse wheel; to pan an image bigger than the window, simply left-click and drag your mouse around.

Two settings don't just apply to the currently displayed image and are remembered when browsing from one image to the next:
High quality zooming applies a very fast filter when zooming to reduce jagged lines and produce a smoother result.
Stretch to window will stretch smaller images to fill the current window frame.

Then there's a Full screen mode with an option to Show caption in full screen mode which overlays the file name at the bottom of the image.

Lastly, Show tool bar will show/hide the graphical controls:

showimage-toolbar.png

From left to right: Previous image, next image, start slide show (in full screen mode), selection mode, original size, fit to window, zoom in, zoom out, previous and next page (when an image format like TIFF allows multiple pages in one file, see below).

Most of the more often used commands are also available from a right-click context menu on the image. Convenient when in full-screen mode.

indexBrowsing

showimage-browse.jpg

After opening an image you can quickly browse through all the other images in its folder (or query result window) by pressing / or /. You can see the selection change accordingly in the Tracker window.

There is a quick way to open the folder of the current image and even navigate to its parent and subfolders. It works just like with drill-down navigating in Tracker by clicking in the info area in the status bar that shows size and format of the current image.

Looking at the Browse menu, shows another type of browsing: Some image formats, like TIFF, can contain several pages in one file. Commands like First page and Next page let you navigate those pages.

indexEditing

showimage-edit.jpg

The Image menu offers the few image manipulations necessary for an image viewer: rotating and flipping the image. Note however, that the actual image data won't be changed. Only an attribute is added to the file so it'll be shown rotated or flipped the next time you open it.

Use as backgroud... will open the Backgrounds preferences to set the current picture as image for your workspaces.

Cropping is another feature that's needed sometimes. To define the frame to cut to, you can switch to Selection mode from the Edit menu and drag out a box with your left mouse button. If you don't want to change modes first, you can create this box in "normal mode" by simply holding CTRL while left-click-dragging, which otherwise would just pan the image around.
Clear selection or ESC will remove the selection box.

The following chapter shows how to actually save the cropped area.

indexSaving and converting

To save or convert an image into any available format, you can invoke the normal Save as... item from the File menu, select the format and choose a file name.
Often quicker, especially when the Tracker window with the destination folder is already open, is using drag & drop.

showimage-dnd.jpg

This is also how the above mentioned cropping is finalized. Either select a frame as described above, or choose Edit | Select all for the whole image. Then drag & drop the selection onto the Desktop or any Tracker window to create a new image clipping in the same format of the original image.

To save in another file format, do the dragging with the right mouse button and choose a format from the context menu when dropping the image.

indexKeyboard shortcuts

Here's a list of the most useful shortcuts:

/ Previous image
/ Next image
DELMove to Trash
+Zoom in
-Zoom out
0Original size (100% zoom)
1Fit to window
ALT ENTERToggle full screen mode (also via double-click)
CTRLWhile holding CTRL you can create a selection frame without explicitly switching to selection mode.